שלח תשובה

זירת השאלות

562
צפיות
0
תשובות

עדכונים נדרשים לתסריט

,‏ 23 באפריל, 2013
הודעה זו נכתבה בתגובה למאמר: סקריפט להצגת המלצה לשדרוג דפדפן

התסריט הנ"ל אינו תקין מזה זמן מה, ולמעשה יקפיץ הודעת עדכון לפיירפוקס לכל אדם שישתמש בגרסה העדכנית ביותר (20) ומעתה והלאה, וכיום גם אין שום הגיון לדרוש ממשתמשים לעדכן לגרסה 9 של אינטרנט אקספלורר כאשר הגרסה החדשה (10) הרבה יותר טובה מבחינת התאימות שלה בתקנים.

הגישה המקובלת בשנים האחרונות היא לא לזהות דפדפנים מיושנים באמצעות גרסאות ולחסום אותם, אלא לזהות תכונות ולהציג את ההודעות הללו בהתאם לתכונות שאינן נתמכות בדפדפנים אלו. ביצוע שינוי כזה יאפשר לאתר להציג את ההודעה כאשר תכונות חשובות לתפקוד האתר אינן נתמכות, ולא ידרוש לנהל רשימת גרסאות נתמכות ולהידרש לעדכנה באופן שוטף.

כמו־כן, בהמשך לדבריו של ידידנו גיא בורנשטיין ממיקרוסופט, גם אני חושב שכדאי לנהל את קוד התסריט ב־github, כך שיהיה לאנשים קל יותר להציע שיפורים עבורו ולמתחזקי התסריט לעדכן את המשתמשים בגרסאות חדשות.

תגיות:

0 תשובות

    שלח תשובה

    חדש! אחסון אתרים של וובמאסטר

    שירות אחסון אתרים
    המקצועי של וובמאסטר!

    מומחים באירוח אתרי
    WordPress, Joomla, Drupal

    • שרתי לינוקס עם CloudLinux, LiteSpeed
    • 1GB דיסק SSD, 10GB תעבורה חודשית
    • ממשק ניהול cPanel, תעודת SSL חינם

    עכשיו במחיר היכרות:
    רק 420 ש"ח לשנה!