שלח תשובה

זירת השאלות

536
צפיות
6
תשובות

WAP, WML וסלולרי

,‏ 6 בדצמבר, 2005

שלום לכולם 🙂
התחלתי לנסות לעבוד מול WAP – בניית אתר לסלולרי. הכנסתי את הקוד הכתוב בהמשך לדף, שמרתי בסיומת WML ונכנסתי מהסלולרי וקיבלתי שגיאה. בעיקרון על הדפדפן במחשב אין שגיאה, והעתקתי את מה שכתוב ממדריך ברשת (ניסיתי גם את מה שכתוב כאן בוובמאסטר). למה אני נתקל בשגיאה?
השגיאה:

Server Error
Web server/WAP geteway error


הקוד:

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Paragraphs"> <p>
This is a paragraph
</p>
<p>
This is another<br/>with a line break
</p></card>
</wml>

שם הקובץ – a.wml

האם יכול להיות שהשרת עצמו בכלל לא תומך ב-WAP, או במה שהוא כן צריך לתמוך על מנת להפעיל את הדף מהסלולרי?

תודה רבה

תגיות:

6 תשובות

  1. זהר פלד הגיב:

    כנראה קינפוג של השרת.
    ה wml עצמו נראה תקין לגמרי.

    צריך לודא שהשרת יודע לשלוח content-type של wap.
    יש מאמר באתר על קינפוג של iis לתמיכה ב wap.
    אם אתה עובד עם שרת אחר, כגון tomcat או אפאצ’י, אני לא יודע איך מקנפגים אותם.

  2. YuvalS הגיב:

    תודה רבה על התשובה
    אני עובד מול שרת שעליו נמצא אתר אינטרנט קיים. פונה לכתובת בצורה ישירה.
    האם עלי לבדוק עם חברת האחסון את עניין השליחת content-type של WAP? או שעם חברת האחסון אני צריך לדבר בנושא שונה?

  3. YuvalS הגיב:

    עדכון – בעיה חדשה
    פניתי אל צוות התמיכה ואכן היה צורך בהתקנה כלשהי. בכל מקרה, הרכיבים הותקנו.
    כרגע ניסיתי להכנס אל הדף ומוצגת לי השגיאה הבאה מהסלולרי שלי:
    "מבנה קובץ לא מוכר"

    האם הבעיה היא בקובץ עצמו שאני מנסה לגשת אליו (מדובר באותו קובץ שהצגתי כאן, לא נגעתי בו) או שמה עדיין יש בעיות מהצד הטכני של השרת? מה ניתן לעשות?

    תודה רבה.

  4. YuvalS הגיב:

    מישהו? 🙂
    האם הבעיה היא בקוד של העמוד או בשרת עצמו?

    תודה 🙂

שלח תשובה